WD14 print function
June 22, 2009 02:26PM
We have developed finhosta a few years ago in WinDev 12. In the program there is a possibility to print a report. Until recently it worked perfectly, but since the convertion to the newer version, WinDev 14, we encounter a bug with the print function.
Normally when you click on the print button, it opens a wizard to choose your printer and options... When you click on "OK" it wil be printed. In the newer version it still opens the wizard but when you want to click on the "OK" button it is visible but not clickable.
In WinDev 12 it always worked so I think it is a problem in WinDev itselfs.

Kind regards,

Sofie Van Der Bruggen
Junior Programmer @ Aexis

Edited 1 time(s). Last edit at 06/22/2009 02:40PM by Sofie.
Re: WD14 print function
June 25, 2009 06:00PM

I am also looking at the problem with this Finhosta application and have some additional information.
It seems that the problem is only located when we run the function ipreview ()
If we use the iprint () function there is no issue.

Code used is:

ipreview (i100)

If you have any suggestions please let us know. Also, is there any way to debug a built in function like this?

Re: WD14 print function
August 09, 2010 01:25AM
Please read what I did and was able to correct below;

In an application I've created initially using the RAD, I created reports via the REPORT EDITOR. When I associate the report with a FORM or TABLE the PREVIEW opens and shows the report. When I click on the printer image in the upper left corner the print select window opens. I click on the PRINT button and nothing prints.

I then remove the associated report on the FORM or TABLE PRINT BUTTON and in the PRINT BUTTON click code area I enter the IPRINTREPORT command and use the wizard to setup the IPREVIEW and IPRINTREPORT. example;

iPrintReport(RPT_Repair_work_Order_form, WIN_Form_Repair_workorders.SC_Form.BCOD_BarCode1,WIN_Form_Repair_workorders.SC_Form.BCOD_BarCode1)

This too does not print the report. But if I comment out the IPREVIEW the report prints directly with success.

NOW, I open another project and reuse the data to RAD a form. I GO the form and click the PRINT button....the preview opens so I click on the printer image in the upper left corner and the report prints like it should!

Any suggestions on the what I've set wrong in the original application and what I can do to correct it?

Thank you for your assistance an insight in advance!

RESOLVED - from the menu select PROJECT, PROJECT DESCRIPTION, STYLE, under the PRINT PREVIEW section at the bottom I had "To the skin template of the project" selected. Changed to the "Standard (no skin template)" selection and now prints as expected.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.