Welcome! Log In Create A New Profile

Advanced

Bug with Radiobuttons

Posted by Scott 
Scott
Bug with Radiobuttons
August 03, 2011 11:04PM
WinDev 16
RAD generated data entry window for a non-relational database
Five choices for the radio buttons
Display mode = STANDARD

Why won't the TAB key select the radio buttons on the data entry screen? The cursor will jump OVER the radio buttons to select the next data entry field located directly under the radio buttons. If I use the TAB key to cycle through all of the data screen elements the radio buttons are NEVER selected.
Al
Re: Bug with Radiobuttons
August 07, 2011 07:07AM
Hello Scott

I think it might be better to post this in the forum as I don't think it is a bug
.
Check that your radio button is ticked as "Accessible by Tab" in the GUI section of the control editor.
You can use the F5 key to see the tab sequence on a window and then while the window is open use the "Windows" option in the main menu bar of the IDE and select Tab order to adjust the sequence.
Also be aware that in my opinion, code produced by the RAD tool in Windev is not production ready and is not the best example of coding, however it is a great learning tool.

Regards
Al
Scott
Re: Bug with Radiobuttons
August 08, 2011 03:54PM
Yes- the checkbox for "Accessible by Tab" is checked - if I MODIFY an existing database record in the form then the radiobutton is accessible - if I ADD a new record to the database the radiobutton isn't accessible - the tab key "skips" over the radiobuttons displayed onscreen to the next entry field.

That is a bug in my book...
Al
Re: Bug with Radiobuttons
August 08, 2011 11:14PM
Hello Scott

I have similar handcoded screens doing edits, browses and adds and the tab order always works fine. The tab order can be adjusted with zorder commands and returntocapture() and screenfirst() can also alter the order.
The RAD code could also be making the radio button inactive either directly or via the group the button belongs to.
Is there any code altering the ..state of controls or groups ?
In the ADD method, is the radio button active and you can click on it to select an option ?

The reason I am persisting with this is that I have never come across the problem and as I said earlier I am not a fan of the RAD code so I am suspicious that it is the cause rather than it being a Windev bug.

Regards
Al
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: