Welcome! Log In Create A New Profile


[WD22] - Compilation error

Posted by Erik Schwarz 
Erik Schwarz
[WD22] - Compilation error
November 07, 2019 05:29PM

as a sudden I get that error when compiling:


The generation failed.
Unable to open <D:\A22-Entwicklung\A19-TT7-Entwicklung\TimeTouch-Version7\TimeTouch7.cpl\ERIK\00000002\GP_Alle.1E9F3319.wdg.wcg> file.
System Error Details:

Der Prozess kann nicht auf die Datei zugreifen, da sie von einem anderen Prozess verwendet wird.

No other process as far as I know is running.
Did a recompile
Did delete the mentioned file, then another one is concerned.
Did delete the cpl Folder.
Did restart the pc.

All with no effect.

Any ideas?

Re: [WD22] - Compilation error
November 07, 2019 05:33PM
Hi Erik,

Can you delete the .wcg file?

Kind regards,
Re: [WD22] - Compilation error
November 07, 2019 05:46PM

The "1E9F3319.wdg.wcg" in the error message looks a little strange, but might be quite valid?

The only "standard" action I can't see in the list of what you've tried so far is a Project Repair.

If that doesn't fix it, I would then try backing up your project and restoring it into a new project folder; essentially duplicating the project.

Re: [WD22] - Compilation error
November 07, 2019 06:01PM
The WCG filei s Information for compiling a set of procedures (re-created after each compilation)

Did you try to open one procedure inside the GP_Alle set of procedures?

Are this set of precedures shared wtih other projects?


Paulo Oliveira
Erik Schwarz
Re: [WD22] - Compilation error - SOLVED
November 07, 2019 06:13PM
Hi ,

thanks for all hints.
Finally a 'repair the project' instead of 'recompile' did it smiling smiley


Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.