Welcome! Log In Create A New Profile


Azure date issue

Posted by ArieM 
Azure date issue
October 31, 2019 05:05PM

we are in the middle of moving our application and MSSQL database to azure. Everything is running fine in the current environment, dedicated 2012 server with mssql 2012.
I copied the application (WD23) to a Win2019 instance in Azure. It is still connecting to our current databaseserver (not Azure).

Normally dates are formatted like 20191031 when looking at the record buffer after reading a record. Then when displaying the date it can be in any format, like DD-MM-YYYY and so on.

However I face a strange thing with with dates when running the application from our new Azure instance. . The dates in the record buffer are malformed and look like this
and that's it. Still 8 character long but it is missing de day part due to the 2 minus characters??

Afaik it hasn;t anyting to do with "display" in WD, it looks like the recordbuffer already has wrong data.
I tried for example the next 3 lines

And it comes with 2019-10- instead of 20191031

I tried different combinations of language/regional settings, with no help. (howefer the recordbuffer shouldn't change by that)
It happens with the default OLEDB driver as well as with the Windev native mssql driver.

I must be missing something, but have no idea yet. Any help appreciated!


Edited 1 time(s). Last edit at 10/31/2019 05:24PM by ArieM.

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.