Welcome! Log In Create A New Profile


[WD24] MS SQL error

Posted by Al 
[WD24] MS SQL error
October 16, 2019 06:13AM
Hello All

I have a problem with updating records in MS SQL from HF Classic files.
My client has 9 different companies, all completely separate from each other in separate directories, but on the same server. Each company has exactly the same database and Windev exe.

A change log is maintained for each company to log the primary key of every HF record that has an add, delete or modify during the day and each night the change log for each company is processed and the corresponding data in a MS SQL database - one for each company - is updated from the HF Classic file.

If the update exe is run manually in each company they all work fine.
Over the last couple of days the MS Scheduler has been used to run the exe in each company at night - separate scheduler tasks for each company.

The problem - 8 schedule tasks run and 1 doesn't

The company that doesn't work on the scheduler still works if I run the exe manually.
The other point of interest is that once, when running the initial tests manually, the company that doesn't work in the scheduler stopped with the following error.

What happened?
native SQLSERVER access error.
Error Number = 117

Error 80004005 returned by SQL Server
Description: Login timeout expired
SQL State: HYT00
SQL Error Number: 0

After the error, I ran the exe again and it all worked fine

The file that it failed on was the first one in the list and had 735,000 records but there are larger files in the other companies that update ok. The failure was on an insert to add a record from the HF Classic file into the corresponding SQL file.

I don't know the result code from the schedule task yet. The tasks were setup by my client's tech people and they haven't got back to me yet.

The SQL files are described in the Windev analysis and I use the V24 version of the MS SQL Native Update
The authentication from Windev to the SQL server uses Windows Authentication.

I think it must be an issue at the MS SQL end but have no idea where to look.

Re: [WD24] MS SQL error
October 16, 2019 10:15AM
Your problem is the login to MSQLSERVER not in the INSERT.
If it's Windows Authentication check the user defined in the schedule task.
When you run it manually it uses the user logged in, when in schedule task it uses the user defined to run the task.


Paulo Oliveira

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.