Welcome! Log In Create A New Profile


[WD23] dResize has lost its marbles?

Posted by Ola 
[WD23] dResize has lost its marbles?
August 15, 2019 01:16PM
Has anybody else noticed this weird, unexpectedly changed behaviour of the dResize command?

dResize worked OK in my program until last year's summer but then it started to give weird results. This suggests that the fault came when I "upgraded" from WD21 to 23 (skipping 22).

Earlier it worked as documented but now the new size is larger than defined and there is a white margin to the right and to the bottom of the result image.

For instance, I have an image sized 300 px wide x 216 px high (no white margins). I try to make a smaller thumbnail of it sized 180 (CalculatedWidth) x 130 px (CalculatedHeight) with the command

ResRes = dResize(Image, CalculatedWidth, CalculatedHeight)

The result is sized 216 * 156 pixels, and it has very wide white right and bottom margins, and the actual image in the left upper corner is stretched lenghtwise!

Can somebody explain, what has happened, and advise if there is a way to fix this.
Any help will be much appreciated.

Best regards
Re: [WD23] dResize has lost its marbles?
August 16, 2019 02:53PM
Problem solved.
Earlier (in WD21) I had done the resizing in an image control, but this does not work any more (in WD23) without weird side effects.
After some testing, I found that by doing the resizing in an image variable, it works correctly.
Another additional cost of "upgrading": one day.angry smiley

Best regards

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.