Welcome! Log In Create A New Profile


WD problem deploying a webservice

Posted by Lee Shroder 
WD problem deploying a webservice
March 05, 2019 08:48PM
Hi Everyone,

I am having an awful time trying to install a Windev developed Web Service. (Windev 23)
I have installed what is now called the Reserved Application Server and it connects fine with IIS as it passes all of the configuration checks within its diagnostics.
The problem I face is when trying to install a Windev developed webservice as the installer never see's the application server.

The generation is set to Create a setup by physical media or webservice.
The application server is installed into the path C:\Program Files (x86)\PC SOFT\Reserved Server 23 and if I run the RServer23.exe it runs ok adn passed all diagnostics in terms of IIS settings.

However when I run the installer created by Windev I get a message advising me that the WEBDEV Application Server was not found on my PC and clicking next requests me to select a folder where the WEBDEV Application Server will be installed.

This defaults to:-C:\Program Files (x86)\PC SOFT\WEBDEV\23.0\

Choosing this folder and selecting the default options for the webservice install I get the following error:-

Error at line 19 of Méthode __bLireInfoDansUnFichierCompte process ('CompteWebDev' component).
HReadSeekFirst function called.
Unable to open <C:\Users\Lee\AppData\Local\Temp\WD_5A37.tmp\wbcompte.FIC> file.
File found neither on disk, nor in libraries (.WDL) or components (.WDK).

System Error Details:

The system cannot find the file specified.

----- Technical Information -----

Project : WBSetup
Component : CompteWebDev

WL call:
Process of 'Méthode __bLireInfoDansUnFichierCompte' (CClientWebDev.__bLireInfoDansUnFichierCompte), line 19, thread 0
'HReadSeekFirst' function, syntax 1

What happened?
Unable to open <C:\Users\Lee\AppData\Local\Temp\WD_5A37.tmp\wbcompte.FIC> file.
File found neither on disk, nor in libraries (.WDL) or components (.WDK).

Error code: 70003
Level: fatal error
WD55 error code: 3

I checked the suggested install folder of C:\Program Files (x86)\PC SOFT\WEBDEV\23.0\ and this doesn't exist.

I have also tried running the installer as Administrator just in case it was a permissions thing but this didn't help.

Does anyone have any idea what the problem is and how I can resolve it please?

Thank you for any assistance.

Kindest Regards,

Re: WD problem deploying a webservice
March 06, 2019 08:15AM
Hi Lee,

It looks like you installed the wrong server.
Afaik the one you mention is a webservice itself, allowing you the get access to server databases from a remote client directly. Defining a connection to this webservice and using regular H-commands as if the database was local on the device.

My guess is you developed a webservice by your self and in that case you need the 'normal' webserver found here
Either the unlimited payed version or the free 10-user version. You don't need a WB license if you are using the webserver only for webservices (which indeed can be developed with WD)

Re: WD problem deploying a webservice
March 06, 2019 09:28AM
Hi Arie,

Oh dear it was that simple, thank you Arie I can't believe I missed that. I haven't worked on Webservices wiith Windev for about 3 years and I didn't even think to look for the download from Windev I assumed it would be in the applications provided with the installer and thought the install I found was the right thing.

Thank you very much for your help thumbs up smiling smiley

Kindest Regards,

Re: WD problem deploying a webservice
March 06, 2019 06:48PM
This well-ordered article tells you the best way to compose a straightforward Web administration, SEM Management Agency Math Service, that uncovered strategies for including, subtracting, separating, and duplicating two numbers

Your Email:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.