Welcome! Log In Create A New Profile

Advanced

WD slow environment when debugging

Posted by ArieM 
WD slow environment when debugging
November 21, 2018 03:49PM
Hi,

is there a way to speed up the WD environment?
Every time I return to the environment (be it at a breakpoint or when exiting the app) Windev comes to the foreground. But every pane, ribbon, etc seems to be repositioned and redrawn one after the other. Very annyoing.

It takes at least 5 seconds to get at a breakpoint and be able to coninue working confused smiley
And I use breakpoint a LOT.

Arie
Re: WD slow environment when debugging
November 21, 2018 05:22PM
Hi Arie,

same to me. What WD version do you use (me=WD22)

regards Michael
Re: WD slow environment when debugging
November 21, 2018 08:11PM
Yes V22.

V23 seems to do the job better, But this is a huge project, did not have time to migrate yet.
I don't expect much problems but still…

Arie
Al
Re: WD slow environment when debugging
November 26, 2018 08:01PM
Hello Arie

Try turning off the display of Global variables in the debug window. If you have a lot then this does slow thw debugger down considerably.

Regards
Al
Re: WD slow environment when debugging
November 26, 2018 09:15PM
Hi Al

Didn't think of that, so thanks.
But it's already turned off....

Arie
Re: WD slow environment when debugging
November 27, 2018 06:23PM
Hi,

I'm having the same problem, Windev 22 is sluggish.

Kind regards,
Piet
Author:

Your Email:


Subject:


Spam prevention:
Please, enter the code that you see below in the input field. This is for blocking bots that try to post this form automatically. If the code is hard to read, then just try to guess it right. If you enter the wrong code, a new image is created and you get another chance to enter it right.
Message: